Delay in Tracking Updates from Aquiline on Orders
Incident Report for AutoDS
Resolved
This incident has been resolved.
Posted Feb 25, 2024 - 23:58 UTC
Investigating
Some customers are experiencing delays on tracking number updates from Aquiline on their orders.
Our team is monitoring the situation closely.
Posted Feb 23, 2024 - 09:35 UTC