Amazon Auto-Orders fail with error: Unable to get item details from AutoDS
Incident Report for AutoDS
Resolved
This incident has been resolved.
Posted Jun 15, 2024 - 23:32 UTC
Investigating
We have detected issues with Amazon Auto-Orders (US and DE)/FBA that fail with error: "Unable to get item details from AutoDS. Please contact support for further assistance".

We are currently addressing this issue.
Thank you for your patience.
Posted Jun 15, 2024 - 08:33 UTC
This incident affected: AutoDS Auto Orders.