Automatic messages are being sent to customers multiple times
Incident Report for AutoDS
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 06:48 UTC
Investigating
Our team is actively investigating the issue and will ensure you receive consistent updates regarding its status. Thank you for your understanding.
Posted Mar 25, 2024 - 20:29 UTC
This incident affected: AutoDS Auto Orders.