Fulfilled by AutoDS Amazon orders temporary limit - Service expansion
Incident Report for AutoDS
Resolved
This incident has been resolved.
Posted Oct 17, 2022 - 08:49 UTC
Identified
We have become aware of the fact that our users are experiencing a delay in both processing orders and tracking updates by Fulfilled by AutoDS Service.
This is because the FBA service is currently limited due to large demand.
At the moment, each AutoDS user will be limited to up to 20 orders a day for items below $25 and no limit for greater value.
We are in the process of scaling up the service and hope to have it running with no limits again in a few days, or up until further notice.
We do suggest that in the meantime you raise your handling days to 5 to avoid any issues.
We are diligently working and monitoring the situation closely, we will continue to update the progress here regularly to keep you all posted.
Thank you for your patience and understanding.
Posted Jul 20, 2022 - 07:28 UTC
This incident affected: AutoDS Auto Orders.