Delay in Fulfilled by AutoDS orders due to Thanksgiving.
Incident Report for AutoDS
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 12:28 UTC
Investigating
The orders that are being processed with the FBA service are in delay due to the Thanksgiving holidays.

This is expected, as in every year, and all stores using the FBA service are being advised to prolong their handling and shipping times at least throughout the weekend.

If you have your own accounts you can also use them to push some urgent orders, but again be mindful of your handling/shipping times.
Posted Nov 25, 2022 - 09:52 UTC
This incident affected: AutoDS Auto Orders.