AutoDS page is unclickable, new Shopify users are being asked again by the system to add a store
Incident Report for AutoDS
Resolved
This incident has been resolved.
Posted Jul 14, 2023 - 12:09 UTC
Investigating
We are currently investigating the issue
Posted Jul 14, 2023 - 10:15 UTC
This incident affected: AutoDS Platform.